Article delegate-en/3667 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A3665@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Questions about SSLway
21 Mar 2007 15:10:26 GMT feedback@delegate.org (Yutaka Sato)
The DeleGate Project


Hi,

In message <_A3665@delegate-en.ML_> on 03/21/07(17:27:45)
you "Kwis Angelo" <phyhabdyi-re5dixrruhtr.ml@ml.delegate.org> wrote:
 |I think I have found the right parameter to run Delegate with the right
 |client certificate.  But we had some problems when establishing a session
 |with the HTTPS site;
 |
 |====================================================================
 |
 |$/delegated -v -P$DELEDATE_LISTNER_PORT SERVER=http STLS="fsv,sslway -Vrfy
 |-CAfile pems/CA.crt -cert pems/ggs-delegate.crt -key
 |pems/ggs-delegate.key-pass pass:1234" MOUNT="/* $HTTPS_HOST_URL/*"
 |RES_WAIT=0 ADMINPASS=gemuser
 |DGROOT=/opt/delegate951
...
 |03/20 17:42:27.34 [22869] 7+1: willSTLS_SV: ServerFlags=30

I noticed that the log shows that DeleGate is not applying SSL with
the server.  It is because your command line seems to include
the ":" character int the options for SSLway.  In such case, you need
to wrap the SSLway options with { and } as follows: 

 STLS="fsv,{sslway ... argument including : ... }"

Cheers,
Yutaka
--
  9 9   Yutaka Sato <y.sato@delegate.org> http://delegate.org/y.sato/
 ( ~ )  National Institute of Advanced Industrial Science and Technology
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
Do the more with the less -- B. Fuller

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V