Article delegate-en/3666 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
[Reference:<_A3665@delegate-en.ML_>]
Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Questions about SSLway
21 Mar 2007 10:04:09 GMT feedback@delegate.org (Yutaka Sato)
The DeleGate Project


Chris,

In message <_A3665@delegate-en.ML_> on 03/21/07(17:27:45)
you "Kwis Angelo" <phyhabdyi-fjxi26hzzhtr.ml@ml.delegate.org> wrote:
 |*$/usr/local/ssl/bin/openssl s_client -connect winapi.wireless.co.id:443-CAfile
 |CA.crt -cert ggs-delegate.crt -key ggs-delegate.key -state*
....
 |But when we force openSSL to use SSLV2, it works fine!  We are using a
 |Solaris9 OS.
 |We are quite puzzled because using SSLV3 on a Solaris10 works well...so now
 |it seems that the problem is isolated to Solaris9...
 |
 |At this point, we are forced to use the Solaris9 machine to install
 |Delegate.  Now my question is...is there a way to force Delegate to use
 |SSLV2 ?

You can do it with "-ssl2" option for SSLway as this:

  FSV="sslway -ssl2 ..."


 |If you have experienced SSLV3 errors on Solaris9, it would be really be a
 |big help if you can share some insights on it too.....

I have no experience with Solaris9.
I think the problem might depend on the version of your SSL library which
you can see in the LOGFILE, or you can test it with "-Fver" option as this:

 % delegated -Fver
 ...
 Loaded: OpenSSL 0.9.8d 28 Sep 2006


Cheers,
Yutaka
--
  9 9   Yutaka Sato <y.sato@delegate.org> http://delegate.org/y.sato/
 ( ~ )  National Institute of Advanced Industrial Science and Technology
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
Do the more with the less -- B. Fuller

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V