Article delegate-en/3078 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: Outlook Web Access
22 Nov 2005 14:26:05 GMT Conrad Mario <paygabdyi-4qjvf2mkmc3r.ml@ml.delegate.org>


Hi,
We were able to "solve" this problem or at least to find au where the
problem lies. So maybe one has an idea based on what i'm going to write how
to come around with a good solution. 

It is possible to write a filter plugin that checks all incoming http
packets and changes the inital adress from the http://10.1.1.3/exchange
<http://10.1.1.3/exchange>  to http://yourdelegate/exchange
<http://yourdelegate/exchange> , because the genereated html page (and it's
javascrip files) you see always points to the "real" ip address of the (or
nat ip address if you try from the outside). And if the nat adress (or real
address) is not directly reachable from the outside you see the first
preview of the OWA interface, but if you click on a mail the popup points to
the nat (inside) address what doesn't work.

Here my delegate start advice:

delegated -P80 SERVER=http MOUNT="/* http://exchangeNATip/*
<http://exchangeNATip/*> " FTOSV="/var/log/del
egate/adm/filter1" PERMIT="*:*:*" ADMIN="informatik@azag..ch"
LOGFILE="/var/log/d
elegate/delegate.log" DGROOT="/var/log/delegate" HTTPCONF=methods:*

Here my filter1 bash script:
----
#!/bin/bash

while read LINE; do
 echo "$LINE" | sed -e 's/NATIP/DELEGATEIP/g'
done
---

Hope someone got an idea out of this. Cause this solution is VERY slow...
If you find out please let me know.

Regards,
Mario

From: Hiroshi Suzuki <pxyuabth4-4qjvf2mkmc3r.ml@ml.delegate.org>
Date: 18 Apr 2002 01:46:16 GMT
Message-ID: <_A1614@delegate-en.ML_>
--
Hi,

That HTTP server needs special 'HTTP METHOD' that ignored by DeleDate
normaly ?
Please try option followed,

HTTPCONF=methods:'+,PUT,DELETE,PROPFIND,PROPPATCH,MKCOL,COPY,MOVE,LOCK,UNLOC
K'

Ronald Drexler wrote:
> Yutaka:
>  
> Thanks for the response.
>  
> Yes - the site works fine from my private LAN (http://10.1.1.3/exchange
<http://10.1.1.3/exchange> )
>  
> Regards,
> Ron

H.S.



  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V