Article delegate-en/2958 of [1-5169] on the server localhost:119
  upper oldest olders older1 this newer1 newers latest
search
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]

Newsgroups: mail-lists.delegate-en

[DeleGate-En] Re: delegate running as https service
02 Jun 2005 00:08:41 GMT "James Brooks" <ppufqbdyi-rcwevef6oulr.ml@ml.delegate.org>


Again, sorry to bother you but I am still having problems with HTTPS
redirects. I have downloaded every version of sslway that is on your ftp
site under sslway old.  I noticed that you log file claims you compiled
the win32 9.0.0 version of delegate 050413, So I downloaded all versions
of sslway from sslway-20020226 to sslway-20041208 and still none seem to
fix the problem.  I even download openssl and created a new
server-key.pem and server-cert.pem and placed them in the same folder as
delegate. Still no luck with sites that do http to https redirects.
Such as http://mail.berea.edu which redirects to https://mail.berea.edu


I have tried delegate version 8.11.4 to 9.0.2  Here is my setup.

delegate -f -v -P81 SERVER=https FCL=sslway CMAP=/test/sslway:FSV:https
ADMIN="admin@berea.." RELAY=proxy,delegate:*:*:* URICONV=where:any

Do you see anything I am doing wrong?
Thanks again for all your help and the great product.  

-----Original Message-----
From: Yutaka Sato [mailto:feedback@delegate.org] 
Sent: Wednesday, June 01, 2005 7:15 PM
To: feedback@delegate.org
Cc: feedback@delegate.org; James Brooks
Subject: Re: [DeleGate-En:2959] delegate running as https service

In message
<_A2956@delegate-en.ML_> on
06/02/05(08:04:22)
you "James Brooks" <ppufqbdyi-rcwevef6oulr.ml@ml.delegate.org> wrote:
 |When I try to use 9.0.0 or lower I get an error about Keyfile not
found or wrong:  server-key.pem  and server-cert.pem  and key does not
match cert:
 |
 |If I generate a server-key.pem and server-cert.pem file and place them
in the same directory with delegate will that help?

Maybe.

But the easiest way without generating new certificate is using new
DeleGate (9.0.1 or later) with old SSLway (before 9.0.0) like
CMAP="/path/of/sslway:FSV:https"
Or you can use the cert+pem at src/builtin/config/anonymous-*.pem.

Anyway, I'll fix the problem soon in the next release...

Cheers,
Yutaka
--
  D G   Yutaka Sato <y.sato@delegate.org> http://delegate.org/y.sato/
 ( - )  National Institute of Advanced Industrial Science and Technology
_<   >_ 1-1-4 Umezono, Tsukuba, Ibaraki, 305-8568 Japan
Do the more with the less -- B. Fuller

  admin search upper oldest olders older1 this newer1 newers latest
[Top/Up] [oldest] - [Older+chunk] - [Newer+chunk] - [newest + Check]
@_@V